Workbook_Open() problem in XP
Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Workbook_Open() problem in XP

  1. #1
    Board Regular
    Join Date
    Mar 2002
    Location
    Philadelphia
    Posts
    100
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

     
    i just started using office XP. It seems that excel XP does run my ON OPEN macros the way excel 97 did, it just ignores them. How do I get XP macros to run when the spreadsheet is opened. thanks.

  2. #2
    Board Regular
    Join Date
    Feb 2002
    Posts
    3,169
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi not uncommon XP has additions 97 does notknow and improvements justthe slightest bit will stop it.

    suggest record or write in XP or debug and post effected line we will try to solve.

    HTH

    Rdgs

    Free Excel based Web Toolbar available here.

    Jack in the UK
    J & R Excel Solutions
    "making Excel work for you"

  3. #3
    Board Regular
    Join Date
    Mar 2002
    Posts
    103
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    insted of on_open or whatever it was, its auto_open
    hope this helps
    Will

  4. #4
    Board Regular
    Join Date
    Mar 2002
    Location
    Philadelphia
    Posts
    100
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    the code is simply displaying a userform

    UserForm1.show

    XP ignore the macro all together, is there a difference in how it recognizes macros that are initiated when the workbook is opened? i had some problems with the new security settings (before no macros wouldnt even run), but i figured it out to put the security on low, but it still refuses to run macros on open???????? i thought it would be a universal problem that others were have but maybe not.

  5. #5
    Board Regular
    Join Date
    Mar 2002
    Posts
    103
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

      
    have you tried to use auto_open?
    ps - i just emailed you cos i didnt realise u were online.
    Will

User Tag List

Like this thread? Share it with others

Like this thread? Share it with others

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

 

 
DMCA.com