3345 Unknown or invalid field reference '[txtComments]'.!

Pookiemeister

Well-known Member
Joined
Jan 6, 2012
Messages
538
Office Version
  1. 365
  2. 2010
Platform
  1. Windows
I'm using Access 2010, and I am still new to it. In my table, I added a new field called Comment on my previously created table. So in design mode, inside the design tab I selected "Add Existing Fields" and added a Comment textbox to my form. However when I try to add text to it, it displays the message in this subject line. How can I fix this? Thank you.
 

Excel Facts

Select a hidden cell
Somehide hide payroll data in column G? Press F5. Type G1. Enter. Look in formula bar while you arrow down through G.

Micron

Well-known Member
Joined
Jun 3, 2015
Messages
3,790
Office Version
  1. 365
Platform
  1. Windows
Should have worked - unless you switched to form view while the table was still in design view after adding the table field. Otherwise, I'd put the form in design view, select the control and look at the property sheet data tab to see if the controlsource property is the name of the new table field. Even if it is, try re-selecting it from the list. Also make sure you didn't alter the table field name after adding the control to the form.
 
Solution

Pookiemeister

Well-known Member
Joined
Jan 6, 2012
Messages
538
Office Version
  1. 365
  2. 2010
Platform
  1. Windows
You were right. I must of switched to form view while it was still in the design process. I just deleted the txtComment control and recreated it. One problem fixed, still many more to go. Thank you.
 

Micron

Well-known Member
Joined
Jun 3, 2015
Messages
3,790
Office Version
  1. 365
Platform
  1. Windows
You're welcome. Wish they were all that easy!
 

Forum statistics

Threads
1,176,266
Messages
5,902,244
Members
434,954
Latest member
kchallr00

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top