Disabling F1 and F12 while editing a cell

ndell

New Member
Joined
Sep 29, 2006
Messages
8
I'm trying to disable the F1 and F12 keys.

In my workbook open event, I put:

Application.OnKey "{F1}", ""
Application.OnKey "{F12}", ""

This does the trick until I double-click a cell to edit
directly in the cell. Then F1 and F12 become functional again.

Any suggestions on disabling those keys whilst directly editing a cell?

Thanks.
 

Excel Facts

Fastest way to copy a worksheet?
Hold down the Ctrl key while dragging tab for Sheet1 to the right. Excel will make a copy of the worksheet.

Jaafar Tribak

Well-known Member
Joined
Dec 5, 2002
Messages
8,724
Office Version
  1. 2016
Platform
  1. Windows

Forum statistics

Threads
1,171,254
Messages
5,874,684
Members
433,066
Latest member
Adsmit83

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top