Excel 2007 default format issue

Spaniel

New Member
Joined
May 11, 2009
Messages
15
Hi all,

I have a clear feeling I'm missing something fundamental here, so apologies in advance...

I have an excel spreadsheet containing 2 sheets:
1: Raw Data - The Raw data tab is formatted how I want it, i.e. Dates as dates, Numbers as numbers etc

2: Pivot Table - The Pivot table shows as it is in the raw data, however once I click on a value in the pivot (creating 'Sheet #' of raw data), the values are all in currency format.

I have tried using the 'clear formats' function in the raw data tab, and sure enough they are all currency....

So, to the question - How do I set the default format of these to be 'general' or 'Number' or anything else?

Thanks in advance.

Sam
 

Excel Facts

Can Excel fill bagel flavors?
You can teach Excel a new custom list. Type the list in cells, File, Options, Advanced, Edit Custom Lists, Import, OK
In fact, I've sorted this myself by digging around the Google archives.

If anyone is interested:

  • Go to the 'home' tab on the ribbon.
  • Right click on the 'Normal' option on 'Cell styles' (The bit that allows you to change the colour and format of cells to 'bad', good etc)
  • Click 'Modify'
  • Click the 'Format' button and select 'general as the default style
  • Click Ok
Sam
 
Upvote 0
Thanks much for finding this info; I opened a new document a couple of days ago and every worksheet was formatted for "Date" including any new worksheets I added to the document. Pretty odd...

Thanks again...CC
 
Upvote 0
No problem - I also had another workbook where 1000's of custom formats were created, so have some code for 'delete all custom formats' if anyone needs it.

Cheers
 
Upvote 0

Forum statistics

Threads
1,218,785
Messages
6,144,492
Members
450,549
Latest member
desperato

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Back
Top