Linking worksheets

bschelle

New Member
Joined
Mar 2, 2004
Messages
4
When linking to another worksheet within the same workbook the target cell displays the path and will not display the contents of the source cell. It only occurs in this one cell and all other links are working correctly. I have deleted and rentered the link many times to no avail. What am I missing?
Thanks in advance,
Bill.
 

Excel Facts

Create a Pivot Table on a Map
If your data has zip codes, postal codes, or city names, select the data and use Insert, 3D Map. (Found to right of chart icons).

just_jon

Legend
Joined
Sep 3, 2002
Messages
10,473
Welcome to the Board -- is that cell formatted as Text? [click Format | Cells | Number | check General. ]
 

bschelle

New Member
Joined
Mar 2, 2004
Messages
4
Yes it is. I have it as text so I can enter a number that must begin with zero (03045689).
 

just_jon

Legend
Joined
Sep 3, 2002
Messages
10,473
The cell containing the link [ =Worksheet1!A1 ] cannot be formatted as Text, or it will ignore the formula; format it as General, or give it a Custom numeric format if you must.
 

bschelle

New Member
Joined
Mar 2, 2004
Messages
4

ADVERTISEMENT

Thanks, that worked. Now how can I force the cell to keep or add the first zero that I need? I have to be able to enter a number that is 8 digits and always begins with a zero, ie: 04026338 and also link to the other worksheet.
 

just_jon

Legend
Joined
Sep 3, 2002
Messages
10,473
Try to custom format the cell via Format | Cell | Custom | 00000000 -- note, this is cosmetic only, and your underlying data will not actually have the prefix-0.
 
Master Excel Bundle

Excel contains over 450 functions, with more added every year. That’s a huge number, so where should you start? Right here with this bundle.

Forum statistics

Threads
1,168,025
Messages
5,856,909
Members
431,837
Latest member
megantang

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top