MINUTE’s calculation

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
959
Office Version
  1. 2007
Platform
  1. Windows
I am looking for formula (in a cell F2) to get difference in MINUTES from D2 (system’s time being regularly getting updated) & B2 with a limit in C2

F2=0 IF
EITHER D2 < B2
OR D2 > C2


How to accomplish?
Thanks in advance
I am using Excel 2007
Sheet1

BCDEF
210:30:0011:00:0010:36:18 6

<colgroup><col style="FONT-WEIGHT: bold; WIDTH: 30px"><col style="WIDTH: 64px"><col style="WIDTH: 104px"><col style="WIDTH: 104px"><col style="WIDTH: 64px"><col style="WIDTH: 64px"></colgroup><tbody>
</tbody>
 

Some videos you may like

Excel Facts

Test for Multiple Conditions in IF?
Use AND(test, test, test, test) or OR(test, test, test, ...) as the logical_test argument of IF.

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
12,619
Office Version
  1. 2007
Platform
  1. Windows
Could be.


=SI(D2 > B2,D2-B2,B2-D2)

But what relationship does cell C2 have?
You could give more examples and the expected results.
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
959
Office Version
  1. 2007
Platform
  1. Windows
Could be.


=SI(D2 > B2,D2-B2,B2-D2) formula is not clear

But what relationship does cell C2 have?
You could give more examples and the expected results.

C2=It is maximum time after which F2 should become 0
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
12,619
Office Version
  1. 2007
Platform
  1. Windows
Try this

=IF(OR(D2 < B2,D2 > C2),0,D2-B2)
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
959
Office Version
  1. 2007
Platform
  1. Windows

ADVERTISEMENT

Try this

=IF(OR(D2 < B2,D2 > C2),0,D2-B2)
It gives
12:06:18 AM I need ONLY 6



<tbody>
</tbody>
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
959
Office Version
  1. 2007
Platform
  1. Windows
From my original post F2 has to fill value which shows that 6 minutes have passed since 10:30:00 & system's time is STILL BETWEEN B2 & C2
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
12,619
Office Version
  1. 2007
Platform
  1. Windows

ADVERTISEMENT

Change the format of cell F2 to General

Try this please

=IF(OR(D2<B2,D2>C2),0,MINUTE(D2-B2))
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
959
Office Version
  1. 2007
Platform
  1. Windows
Try this please

=IF(OR(D2<b2,d2>C2),0,MINUTE(D2-B2))[/QUOTE]
Thanks DanteAmor. IT WORKS.........I re-phrased the formula =IF(OR(D2>=C2,D2<B2),0,MINUTE(D2-B2)) with your help

</b2,d2>
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
12,619
Office Version
  1. 2007
Platform
  1. Windows
(Again with problems with the forum editor, delete the formulas)

=IF(OR(D2<B2,D2>C2),0,MINUTE(D2-B2))

<tbody>
</tbody>

<tbody>
</tbody>
 

Watch MrExcel Video

Forum statistics

Threads
1,127,675
Messages
5,626,212
Members
416,168
Latest member
tttt199623

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top