MINUTE’s calculation

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
1,009
Office Version
  1. 2010
Platform
  1. Windows
  2. Mobile
I am looking for formula (in a cell F2) to get difference in MINUTES from D2 (system’s time being regularly getting updated) & B2 with a limit in C2

F2=0 IF
EITHER D2 < B2
OR D2 > C2


How to accomplish?
Thanks in advance
I am using Excel 2007
Sheet1

BCDEF
210:30:0011:00:0010:36:18 6

<colgroup><col style="FONT-WEIGHT: bold; WIDTH: 30px"><col style="WIDTH: 64px"><col style="WIDTH: 104px"><col style="WIDTH: 104px"><col style="WIDTH: 64px"><col style="WIDTH: 64px"></colgroup><tbody>
</tbody>
 

Excel Facts

Create a Pivot Table on a Map
If your data has zip codes, postal codes, or city names, select the data and use Insert, 3D Map. (Found to right of chart icons).

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
15,380
Office Version
  1. 2013
Platform
  1. Windows
Could be.


=SI(D2 > B2,D2-B2,B2-D2)

But what relationship does cell C2 have?
You could give more examples and the expected results.
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
1,009
Office Version
  1. 2010
Platform
  1. Windows
  2. Mobile
Could be.


=SI(D2 > B2,D2-B2,B2-D2) formula is not clear

But what relationship does cell C2 have?
You could give more examples and the expected results.

C2=It is maximum time after which F2 should become 0
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
15,380
Office Version
  1. 2013
Platform
  1. Windows
Try this

=IF(OR(D2 < B2,D2 > C2),0,D2-B2)
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
1,009
Office Version
  1. 2010
Platform
  1. Windows
  2. Mobile
From my original post F2 has to fill value which shows that 6 minutes have passed since 10:30:00 & system's time is STILL BETWEEN B2 & C2
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
15,380
Office Version
  1. 2013
Platform
  1. Windows
Change the format of cell F2 to General

Try this please

=IF(OR(D2<B2,D2>C2),0,MINUTE(D2-B2))
 

hsandeep

Well-known Member
Joined
Dec 6, 2008
Messages
1,009
Office Version
  1. 2010
Platform
  1. Windows
  2. Mobile
Try this please

=IF(OR(D2<b2,d2>C2),0,MINUTE(D2-B2))[/QUOTE]
Thanks DanteAmor. IT WORKS.........I re-phrased the formula =IF(OR(D2>=C2,D2<B2),0,MINUTE(D2-B2)) with your help

</b2,d2>
 

DanteAmor

Well-known Member
Joined
Dec 3, 2018
Messages
15,380
Office Version
  1. 2013
Platform
  1. Windows
(Again with problems with the forum editor, delete the formulas)

=IF(OR(D2<B2,D2>C2),0,MINUTE(D2-B2))

<tbody>
</tbody>

<tbody>
</tbody>
 

Forum statistics

Threads
1,181,182
Messages
5,928,581
Members
436,608
Latest member
nevers0220

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top