Pivot Table - Field Settings - Number Option to Format Missing

sstrachan

New Member
Joined
Mar 22, 2009
Messages
42
I have a problem, I have several Pivot Tables, on some of the Pivot Tables, I am able to select the Pivot Table Filed Option, and use the Selection for Number to change the formating for this Row Data. On several other of my Pivot Tables, this option does not exist. Does anyone know why this is happening and how to fix this? Any assistance will be appreciated.
 

Some videos you may like

Excel Facts

What did Pito Salas invent?
Pito Salas, working for Lotus, popularized what would become to be pivot tables. It was released as Lotus Improv in 1989.

sstrachan

New Member
Joined
Mar 22, 2009
Messages
42
Please disregard. I was able to find the answer. In the event that anyone else has this issue, I was able to find the answer on the web. If the source data contains either text or blank cells, the number button will not appear. I did verify and this worked.
 

extraXL

New Member
Joined
Feb 19, 2013
Messages
2
This just isn't working in Excel 2010. I am trying to access the "Number Format" options within the Field Settings option on a field that I have placed in the Column Labels box. I have ensured that, 1) autofit is off, 2) preserve formatting is on, 3) blank cells removed in data table, 4) no data formatted as text in data table. There is text in the data table, but it is formatted as General number format. I have another pivot table that is essentially identical that does have the option and works as desired. The problem is, when choosing another selection in the slicer, all of the numeric data that I have formatted as "Number/with Comma/No Decimals" reverts back to general. This is ridiculous and maddening. Can anyone help?
 

actjfc

Active Member
Joined
Jun 28, 2003
Messages
412
It happens to me in Excel 2007. I solved it this way: in the original source database I changed the numeric "offender" field format to “General” so they show just plain numbers (there were no blanks o text in this database field). Now the pivot table format options should show up when you right click in the field setting for the rows that had general format in them.

I was working with dates, for some rare reason the dates were out of order and they did not sort correctly so I sort them as numbers first and change the custom format later, now it works fine. The Pivot option "preserve all formatting" has to be checked.

Try it for Excel 2010!

I hope it helps! It was driving me crazy!
 

extraXL

New Member
Joined
Feb 19, 2013
Messages
2
Thank you for your reply. I did end up figuring it out, and it was a combination of two things: 1) blank cells, and 2) columns with non-matching formates (i.e. number and text). It was a very large spreadsheet of data so it took an enormous amount of time to identify and replace all the bad data. Then, the number format option showed up in the field options. Thanks again!
 

Watch MrExcel Video

Forum statistics

Threads
1,122,964
Messages
5,599,071
Members
414,281
Latest member
Engjamal2021

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top