Showing trailing zeros in a cell

bearcub

Well-known Member
Joined
May 18, 2005
Messages
624
Office Version
  1. 365
  2. 2013
  3. 2010
  4. 2007
Platform
  1. Windows
I have a cell formatted as general. I type in 7100, for example, and expect to see "7100". Instead, the formula bar and the cell display "71" which is not "7100". The cell customer formatting is "#,##0".

It looks like my entry has bee divided by 100. If I type in "710000" I see "7100". I don't know where in my computer setting I need to fix. Does anyone know how to fix this?

The other day I became aware of the when I had decimal numbers. The trailing zero in the decimal is missing in the formula bar even though I had just entered a trailing zero (80.4 to 80.40, doe example).

Or, I show 84 in the formula bar and then manually add 2 zeros to show 84.00 in the formula bar.

After pressing enter the zeros disappear from the formula bar but if I have 2 decimal formatting the zeros will display in the cell, not the formula bar.

What setting do I have to adjust on my computer
 

Some videos you may like

Excel Facts

Excel Can Read to You
Customize Quick Access Toolbar. From All Commands, add Speak Cells or Speak Cells on Enter to QAT. Select cells. Press Speak Cells.

bearcub

Well-known Member
Joined
May 18, 2005
Messages
624
Office Version
  1. 365
  2. 2013
  3. 2010
  4. 2007
Platform
  1. Windows
I forgot to mention that if I format the cell as text, type in the numbers then convert the cell to number the zeros will show.

Really strange
 

bearcub

Well-known Member
Joined
May 18, 2005
Messages
624
Office Version
  1. 365
  2. 2013
  3. 2010
  4. 2007
Platform
  1. Windows
I think I found the issue. I remember go into the backstage and went to Advanced on the editing options. I had Automattically inset a decimal point set to 2. I moved it back to zero and it seems okay now. Maybe that was the issue?
 

Watch MrExcel Video

Forum statistics

Threads
1,114,020
Messages
5,545,533
Members
410,690
Latest member
navneetr
Top