Stop Excel 2010 from appending .txt to file with existing extension

stones710

New Member
Joined
Feb 19, 2004
Messages
9
This has nothing to do with "Hide extensions for known file types" being turned on or off.

I think this problem may have to do with Windows 7 vs Windows XP. With Excel 2010 running under XP this does not happen.

Under Win 7 running Excel 2010, when saving a spreadsheet as a tab delimited text file (.txt). Excel 2010 appends the .txt file extension to a file that already has an existing file extension. For my work I must save excel files as xxxxxxx.upl but excel always saves the files as xxxxxxx.upl.txt. This only occurs under Win 7, not XP which is why I think it is an OS issue.

How can I fix this? I am guessing it is a registry fix, but I don't have any ideas of how to fix it. Thanks in advance for any suggestions!

If I add double quotes around the file name I want, like "xxxxxx.upl" the file will save as a tab delimited text file and Excel will then identify the file type as a UPL file.

What I want: xyz.upl

What I get without the "xxxx.upl" file name: xyz.upl.txt


Please try these steps in XP with Office 2010 to see what I mean is happening:

1) Create a text file on your desktop
2) use notepad to put in one word
3) press tab and enter a second word
4) save the file
5) rename the file TAB.UPL
6) drag and drop it into excel 2010
7) now do a File > Save As

Two things will be different:
The field named File name: will already have the file name
The txt file extension will NOT be appended to the existing file name.
The saved file will be TAB.UPL (as desired).

Now try those same steps using Office 2010 on Windows 7.
The field named File name: will be empty???
The txt file extension WILL be appended to any file name that you type in
(unless you wrap the file name in quotation marks)
The saved file will be TAB.UPL.TXT
 

Some videos you may like

Excel Facts

Convert text numbers to real numbers
Select a column containing text numbers. Press Alt+D E F to quickly convert text to numbers. Faster than "Convert to Number"

dermie_72

Well-known Member
Joined
Sep 4, 2012
Messages
1,540
you can cut out step 5 by doing a save as (change the file type to all), and use the file name you wish.

The reason it's not working in excel, is because the option to save as (file type all), is not showing. At least that's what I'm seeing. One solution would be to save the file as a text delimited file, and then remove the .txt from the file extension. Another would be to name the file what you want first, open it up in excel, and do you thing, and just save. It may give you an "some of the formats will be lost", but save it anyway, then open the file up and have a look to see if the change is accepted.

In answer as to why it's not working, I believe it's because the file type all, is no longer available with save as. Solution, try the above, or see if there is another solution out there.

Sorry there wasn't a definitive answer for you.
 

stones710

New Member
Joined
Feb 19, 2004
Messages
9
Thanks dermie for the reply. The problem is that Excel 2010 does have the problem under Win 7 but doesn't have it under XP.
 

Watch MrExcel Video

Forum statistics

Threads
1,123,334
Messages
5,601,012
Members
414,421
Latest member
tonybear1994

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top