Stop long number from rounding, Entry made in cell

go2jared

New Member
Joined
Aug 21, 2004
Messages
33
I am creating a form spreadsheet for my work, where one of the cells/fields requires the user to enter a transaction number. The transaction number is approximately 25 digits long. When the numbers are entered, excel is taking the last 10 or so numbers and replacing them with zeros. I believe that Excel may be rounding the number. The problem is alleviated if the user simply enters a - within the number string, but I don't want them to have to remember to do this.

Is there a quick fix to stop it from doing this? Thanks! I changed the width of the cell and changed the format, using different options, but it does not work.
 

Some videos you may like

Excel Facts

Select a hidden cell
Somehide hide payroll data in column G? Press F5. Type G1. Enter. Look in formula bar while you arrow down through G.

Richard Schollar

MrExcel MVP
Joined
Apr 19, 2005
Messages
23,707
If the number is being entered into a worksheet cell, can you not simply set the format to be text? Then the user won't need to amend what they type.

Best regards

Richard
 

go2jared

New Member
Joined
Aug 21, 2004
Messages
33
Why did that work?

I could swear I tried that before. I just did what you said and it worked. Don't I feel a little sheepish...baaaahhh Maybe I was overthinking it.

Thanks!
 

Watch MrExcel Video

Forum statistics

Threads
1,118,736
Messages
5,573,921
Members
412,555
Latest member
mark84
Top