Tabla posiciones - formula excel 2007

bpxss

New Member
Joined
Mar 11, 2011
Messages
17
Hola, Quiero que en la celda L5 aparezca un 1 si la celda S4 deja de estar "vacia" en decir que si esta vacia no tome como que el valor es cero, y lo mismo cuando las celdas S6 y S8 son llenadas con valores de manera que si las 3 tienen datos la celda L5 tendria un valor de 3. Es para calcular los partidos jugados de un equipo. Lo mismo haria con PG (patidos ganados) PP (partidos perdidos) GF (goles a favor) y GC (goles en contra).

Espero que este claro, la tabla se encuentra en el siguiente link!

gracias


http://img694.imageshack.us/i/excelv.jpg/
 
Last edited:

Some videos you may like

Excel Facts

Format cells as currency
Select range and press Ctrl+Shift+4 to format cells as currency. (Shift 4 is the $ sign).

GersonPineda

New Member
Joined
Apr 12, 2011
Messages
3
Hola bpxss
Porque no subes un archivo (skydive por ejemplo) y dentro del archivo se mas explicito, para trabajar en el y buscar una solucion

Saludos desde Honduras:)
 

GersonPineda

New Member
Joined
Apr 12, 2011
Messages
3
Debes insertar aqui, el enlace de tu archivo, que se aloja en Skydrive (no tu direccion de correo)

Saludos
 

GersonPineda

New Member
Joined
Apr 12, 2011
Messages
3
Estas de suerte!

Te mando un archivo que hace unos 3 años o mas aproximadamente lo elabore para un amigo

1- Hoja "formar jornadas" en la parte superior debes ingresar los nombres de tus equipos (hasta 10), en la columna F y G son para formar las llaves o sea los encuentros entre equipos (esta validado de modo que no podras repetir equipo por jornada y formato condicional por si cometes el error de armar una llave ya existente)
2- Hoja "Resultados" solo debes ingresar los goles
3- Hoja "Posiciones" es automatica
4- Hoja "Busqueda" es para que realices busqueda por jornadas o equipos
5- Hoja "Liguilla" es para un formato de liguilla, quedan los mejores 4 equipos (asi funciona el torneo local en Honduras)

Las hojas estan protegidas sin clave, algunas hojas tienen datos o tablas ocultas auxiliares, solo buscalas

Revisa cada hoja y estudiala bien, espero te sirva

LIGA HONDURAS

Saludos desde Honduras
 

bpxss

New Member
Joined
Mar 11, 2011
Messages
17

ADVERTISEMENT

Muchas gracias por ayudar!

saludos
 

cgcamal

Active Member
Joined
May 2, 2007
Messages
472
Hola bpxss,

Nos gusta el Fútbol verdad? :biggrin:

Favor seguir los pasos mencionados abajo y probar si el resultado es el deseado.

Paso 1: Definifir rangos,
1-) Definí un rango que se llame "Equipo_Local" y asocialo con "=Hoja1!$K$10:$K$32"
2-) Definí un rango que se llame "Equipo_Visitante" y asocialo con "=Hoja1!$O$10:$O$32
3-) Definí un rango que se llame "Goles_Local" y asocialo con "=Hoja1!$L$10:$L$32
4-) Definí un rango que se llame "Goles_Visitante" y asocialo con "=Hoja1!$N$10:$N$32"

Paso 2: Introducir fórmulas en "tabla auxiliar",
1-) En R5:
Code:
[COLOR=Navy]=SI(SUMA(CONTAR.SI.CONJUNTO(Equipo_Local,$Q5,Goles_Local,">=0",Goles_Visitante,">=0"),CONTAR.SI.CONJUNTO(Equipo_Visitante,$Q5,Goles_Local,">=0",Goles_Visitante,">=0"))>0,SUMA(CONTAR.SI.CONJUNTO(Equipo_Local,$Q5,Goles_Local,">=0",Goles_Visitante,">=0"),CONTAR.SI.CONJUNTO(Equipo_Visitante,$Q5,Goles_Local,">=0",Goles_Visitante,">=0")),"")[/COLOR]

2-) En S5:
Code:
[COLOR=Navy]=SI(CONTAR.BLANCO($R5)=0,SUMA(SUMAPRODUCTO(--(Equipo_Local=$Q5),--(Goles_Local<>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Local>Goles_Visitante)),SUMAPRODUCTO(--(Equipo_Visitante=$Q5),--(Goles_Local<>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Visitante>Goles_Local))),"")[/COLOR]

3-) En T5:
Code:
[COLOR=Navy]=SI(CONTAR.BLANCO($R5)=0,SUMA(SUMAPRODUCTO(--(Equipo_Local=$Q5),--(Goles_Local<>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Local=Goles_Visitante)),SUMAPRODUCTO(--(Equipo_Visitante=$Q5),--(Goles_Local<>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Visitante=Goles_Local))),"")[/COLOR]

4-) En U5:
Code:
[COLOR=Navy]=SI(CONTAR.BLANCO($R5)=0,SUMA(SUMAPRODUCTO(--(Equipo_Local=$Q5),--(Goles_Local<>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Local<goles_visitante)),sumaproducto(--(equipo_visitante=$q5),--(goles_local><>FALSO),--(Goles_Visitante<>FALSO),--(Goles_Visitante<goles_local))),"")></goles_local))),"")></goles_visitante)),sumaproducto(--(equipo_visitante=$q5),--(goles_local>[/COLOR]


Paso 3: El más dificil :confused:, arrastrar las fórmulas anteriores hasta la línea del último equipo :biggrin:

Probá seguir los pasos mencionados, creo funciona como se queria, sin mostrar cero si no ha habido partido aún.

Si no te funciona o encontrás algo no suficientemente claro en el procedimiento, subiría el archivo "xls" modificado
que funciona con las fórmulas mencionadas.

Espero ayude,

Saludos cordiales.
 

cgcamal

Active Member
Joined
May 2, 2007
Messages
472
En el post anterior olvidé escribir las fórmulas de Goles a Favor, Goles en Contra, Diferencia y Puntos:p

5-) En V5:
Code:
=SI(CONTAR.BLANCO($R5)=0,SUMA(SUMAR.SI.CONJUNTO(Goles_Local,Equipo_Local,$Q5,Goles_Local,">=0",Goles_Visitante,">=0"),SUMAR.SI.CONJUNTO(Goles_Visitante,Equipo_Visitante,$Q5,Goles_Local,">=0",Goles_Visitante,">=0")),"")
6-) En W5:
Code:
=SI(CONTAR.BLANCO($R5)=0,SUMA(SUMAR.SI.CONJUNTO(Goles_Visitante,Equipo_Local,$Q5,Goles_Local,">=0",Goles_Visitante,">=0"),SUMAR.SI.CONJUNTO(Goles_Local,Equipo_Visitante,$Q5,Goles_Local,">=0",Goles_Visitante,">=0")),"")
Las últimas dos son obvias,
7-) En X5:
Code:
=SI(CONTAR.BLANCO($R5)=0,$V5-$W5,"")
8 -) En Y5:
Code:
=SI(CONTAR.BLANCO($R5)=0,SUMA($S5*3,$T5*1),"")
Saludos cordiales,
 
Last edited:

Watch MrExcel Video

Forum statistics

Threads
1,122,499
Messages
5,596,515
Members
414,074
Latest member
Matthew Kakde

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top