Unable to Load A Text File

LynneM1

New Member
Joined
Dec 14, 2006
Messages
41
Hello,
I received text files and as I usually do tried to link to them. The result was this message:

does not contain data, or the file is too large

I reduced the size of one of the files to a few lines and recieved the same message.
I Compacted and Repaired the Database and tried again - same message.
I created a blank database using Access 2007 and tried to import the data -same message.
I tried to import past text files that I had no problems with - same message.

Does anyone have any idea what is going on here?

Any help is greatly appreciated.
 

Excel Facts

What is the shortcut key for Format Selection?
Ctrl+1 (the number one) will open the Format dialog for whatever is selected.
As a beginning suggestion can you open the file in Excel as a CSV file and does it add the delimeters?

Also check out the MACRO section about transfertext and look at the arguments below about importing it.
 
Upvote 0
Thanks for responding. These files are very large that is why I have to link to them. Plus I just tried to import an Excel file and received the same message. What is weird is that I never had a problem doing this before and I had the sender test importing the files in his Access 2007 and he had no problem.
 
Upvote 0
What kind of text files are they? Delimited or Fixed Width?
What is the approximate length of each record on your text file?
 
Upvote 0
Hi,
Thanks for trying to help, but this data is not any different and I am using old files for testing so the set up of the files is not relevent. There is something wrong with my software I think. If anyone else has experienced this can you please let me know. Thanks
 
Upvote 0
It is very hard to provide help if you do not provide details to the questions we are asking.

If it worked in testing and it doesn't work now, the three most likely possibilities are:
1. you have a corrupt database (probably not the case, as you rebuilt it)
2. something changed with your data file
3. soemthing changed with how you are performing the task

Importing and Linking can work very differently depending upon what kind of text files you have, as when you import you tell Access exactly what the delimiters are or how long each field is. For a Fixed Width text file, I am not sure how Access knows that if you are just linking them. So I am trying to get a feel for how you are doing this, and if it seems correct.
 
Upvote 0
I am running into the same error message when attempting to use the CMS NPI file (3.5GB), so I suspect that the OP's problem is likely to be that the file is larger than those previously tested.

This thread has a potential solution, as does This link, though I have not yet tested either myself.

Edit: Upon re-reading the initial post, I am curious as to the number of fields in the file. Have you changed from using SQL Server as the engine to Jet? Otherwise I am stumped as to how you previously succeeded.
 
Last edited:
Upvote 0

Forum statistics

Threads
1,216,574
Messages
6,131,496
Members
449,653
Latest member
aurelius33

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Back
Top