Running MAC macros on PC

VandyGrantLab

New Member
Joined
Mar 25, 2009
Messages
2
I recorded and wrote macros in Mac Excel 2004, and I would like to use them on a PC, but they don't work because of differences in how the clipboard holds information when you copy and paste (I think :confused: ). I've searched online, and seen a fix for a specific instance, but I was wondering if you can somehow change the way the clipboard works for Excel on a PC, so that it acts like the clipboard in Mac Excel 2004. Any advice would be greatly appreciated!
 

Some videos you may like

Excel Facts

Will the fill handle fill 1, 2, 3?
Yes! Type 1 in a cell. Hold down Ctrl while you drag the fill handle.

VandyGrantLab

New Member
Joined
Mar 25, 2009
Messages
2
In case it helps, the VB error message I receive reads as follows:

Run-time error '1004':

Paste method of Worksheet class failed


Thanks again!!!!
 

Watch MrExcel Video

Forum statistics

Threads
1,122,469
Messages
5,596,329
Members
414,055
Latest member
mcarduner

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top