Can't Run Macros; Blocked By Security

RandomStu

New Member
Joined
Feb 26, 2010
Messages
2
My hard drive crashed, and I had to re-install Office 2007. I open Excel, and try to open .xlsm workbook I'd created previously. when it opens, I have under the ribbon:

Security Warning Macros have been disabled.

So I click the Options button, and I get:

"Security Alert This file contains encrypted macros that have been disabled because there is no antivirus software installed that can scan them. To run these macros, remove the encryption or permission restrictions on the file."

The only option I'm offered in this popup box is "Help protect me from unkown content (recommended)." I no longer have the option of allowing macros to run, as I did before this hard drive crash.

I do in fact have antivirus software. My ISP is Comcast, and they include in their subscription cost a free Norton Security Suite, which I've downloaded from the Comcast site and have running.

So... what do I need to do so that I can run my macros like before??

Many thanks for any help.

Stuart Resnick
http://www.allexperts.com/ep/1059-73728/Excel/Stuart-Resnick.htm
 

Excel Facts

Did you know Excel offers Filter by Selection?
Add the AutoFilter icon to the Quick Access Toolbar. Select a cell containing Apple, click AutoFilter, and you will get all rows with Apple

texasalynn

Well-known Member
Joined
May 19, 2002
Messages
8,458
Welcome to MrExcel board...

try closing the file with the macro, then setup your security in Excel, after that reopen the file with the macro
 

RandomStu

New Member
Joined
Feb 26, 2010
Messages
2
Welcome to MrExcel board...

try closing the file with the macro, then setup your security in Excel, after that reopen the file with the macro

Kindly let me know what exactly you mean by "setup your security in Excel." Thanks!

Stuart
 

texasalynn

Well-known Member
Joined
May 19, 2002
Messages
8,458
<TABLE style="WIDTH: 815pt; BORDER-COLLAPSE: collapse" border=0 cellSpacing=0 cellPadding=0 width=1086 x:str><COLGROUP><COL style="WIDTH: 815pt; mso-width-source: userset; mso-width-alt: 39716" width=1086><TBODY><TR style="HEIGHT: 12.75pt" height=17><TD style="BORDER-BOTTOM: #ece9d8; BORDER-LEFT: #ece9d8; BACKGROUND-COLOR: transparent; WIDTH: 815pt; HEIGHT: 12.75pt; BORDER-TOP: #ece9d8; BORDER-RIGHT: #ece9d8" height=17 width=1086>Make sure you have the developer ribbon showing; to setup goto the Excel icon in upper left and select Excel options
click on Show Developer tab in ribbon
</TD></TR><TR style="HEIGHT: 12.75pt" height=17><TD style="BORDER-BOTTOM: #ece9d8; BORDER-LEFT: #ece9d8; BACKGROUND-COLOR: transparent; HEIGHT: 12.75pt; BORDER-TOP: #ece9d8; BORDER-RIGHT: #ece9d8" height=17>Click on Developer; select macro security</TD></TR><TR style="HEIGHT: 12.75pt" height=17><TD style="BORDER-BOTTOM: #ece9d8; BORDER-LEFT: #ece9d8; BACKGROUND-COLOR: transparent; HEIGHT: 12.75pt; BORDER-TOP: #ece9d8; BORDER-RIGHT: #ece9d8" height=17>Click Enable all macros</TD></TR></TBODY></TABLE>
 

Forum statistics

Threads
1,136,340
Messages
5,675,202
Members
419,553
Latest member
hanahass

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top