Errormessage while importing .csv file into Access 2010

HerrSober

New Member
Joined
Aug 30, 2013
Messages
40
This is the content of my file testAI.csv

Code:
Common Date,Week,Status,Business Unit,Assignee
2014-08-18,2014 Week30,Closed,Tech Rep,Paul Smith,

When I try to import it in Access 2010 I get the error:

"Text file specification field seperator matches decimal seperator or text delimiter"

As suggested from an article from Tabelousoftware
(source: Resolving "Field separator matches decimal separator or text delimiter" Error | Tableau Software )

This is the reason for this error:

These issues can occur when the data source that you are connected to is a comma separated values (CSV) file that was created on an operating system (OS) with an English locale and being accessed on an OS with a non-English locale

I solution for this should be to create a schema.ini file and put it into the same folder as the file I want to import.
I have edited the dateformat to fit my .csv file. But the errormessage still persists.

This is my file schema.ini

Code:
[testAI.csv]
ColNameHeader=True
Format=CSVDelimited
DateTimeFormat=yyyy-MM-dd
Col1=A DateTime
Col2=B Text Width 100
Col3=C Text Width 100
Col4=D Long
Col5=E Double

I have never wrote a schema.ini file before and am not (yet) an experienced programmer.

I am therefore kindly asking for your assistance in making the schema.ini file correct,

...or something else that might work. :)
 

Excel Facts

Test for Multiple Conditions in IF?
Use AND(test, test, test, test) or OR(test, test, test, ...) as the logical_test argument of IF.
Found a fix. Case closed.


Solution:
Changed the regional settings on the computer. Didn't need to make a schema.ini file after that.

Control panel --> Regional and Language --> Formats (the first tab) --> Additional Settings and there I change to:

Decimal symbol: " . "
Digit grouping symbol: " , "
List seperator: " , "

This is the thread that led me to the solution:

CSV with comma or semicolon? - Stack Overflow

Change Regional regional settings:</SPAN>
http://stackoverflow.com/questions/10140999/csv-with-comma-or-semicolon</SPAN>
 
Upvote 0

Forum statistics

Threads
1,218,620
Messages
6,143,527
Members
450,493
Latest member
Woejeber

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Back
Top