imported text not recognised in vlookup

marleyps

New Member
Hello
I have a problem whereby I have to copy data from my work system into excel and then run a vlookup againt the data.
The problem is that the data is not recognised by the vlookup formula in all cases. the data is part numbers, and is a mix of numerical and alpha numerical.
eg

30524
30536
30568
30569
30584
H1003/45
H1101/44/RE
H1172/40/RE

i run the following code against each line
=VLOOKUP(A1,[PERSONAL.XLSB]KANBAN!$A$1:$B$350,2,FALSE)
and the result should be "Kanban" if there is a match to the lookup table. sometimes the code works but in alot of cases is does not recognise the data . If I overtype the part number and there is a match the code works. I have tried the trim command to remove any leading or trailing spaces, to no avail I am at a loss to understand why the data is not recognised. Any help would be appreciated.

Phill
 

Some videos you may like

This Week's Hot Topics

  • Importing multiple excel files into one spreadsheet
    Hi, I'm trying to import multiple excel files (with the same format into a single spreadsheet) so that each day's file is listed underneath the...
  • find many based on a certain criteria
    good evening, I hope someone can help me? I have a workbook sheet 2 contains lots of data.... I would like to be able to find anything on sheet...
  • How to copy multiple rows using If
    Hi all, I'm very new to VBA and have written this simple code to copy certain cells if a certain cell within that row contains any data. I need...
  • VBA If statement
    Dear All, I have two dates, where I'd like a message box to pop, if the dates are between this criteria. [CODE] sDate1 = #10/1/2019#...
  • Text Format
    I have a sheet for user to keyin the data. The format of the data can be 451 / 1903, 0012 / 9908 or 00287 / 0099. The number after the "/" is...
  • Macro to copy values across rows and transposing them and add the user id
    [FONT=Times New Roman][SIZE=3][COLOR=#000000][/COLOR][/SIZE][/FONT][FONT=Calibri][SIZE=3][COLOR=#000000]Hi,[/COLOR][/SIZE][/FONT] [FONT=Times New...
Top