Inconsistent behaviour opening csv files

TKusters

New Member
Joined
Jun 23, 2008
Messages
2
Hi,

I am getting pretty frustrated with the following:

On PC_A (and all other pc's I tried) I open a csv file (tab delimited) with a .xls extention via file / open. The import wizard starts. Fields with a line feed in it causes Excel to start a new row mixing up the columns.:mad: Opening the same file by double clicking the file in windows explorer opens the file OK without starting the import wizard.:)

On PC_B the file opens the same in both cases: The line feed causes Excel to start a new row instead of an extra line in the cell. :confused:

How can I influence this Excel behaviour? I want to force Excel to stay within the current cell when it encounters a line feed in the import file.
All pc's tested use XP with Office 2003.

Hope anyone can help,
Theo Kusters
 

Excel Facts

Save Often
If you start asking yourself if now is a good time to save your Excel workbook, the answer is Yes

TKusters

New Member
Joined
Jun 23, 2008
Messages
2
Hi Brian,

Thanks for your respons. :)

Unfortunately is doesn't work for me. I think I could get the code to work for me after some adjustments:
The len function doesn't return the correct value, and the string fields are seperated with a ". " characters within strings are doubled to "".

But all other PC's work as expected, only mine is causing trouble. I trying to find the setting that screws things up. I tried already several options, resetting defaults, removing templates, repairing Excel.

Theo
 
Master Excel Bundle

Excel contains over 450 functions, with more added every year. That’s a huge number, so where should you start? Right here with this bundle.

Forum statistics

Threads
1,164,416
Messages
5,837,123
Members
430,477
Latest member
roseinsydney

We've detected that you are using an adblocker.

We have a great community of people providing Excel help here, but the hosting costs are enormous. You can help keep this site running by allowing ads on MrExcel.com.
Allow Ads at MrExcel

Which adblocker are you using?

Disable AdBlock

Follow these easy steps to disable AdBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the icon in the browser’s toolbar.
2)Click on the "Pause on this site" option.
Go back

Disable AdBlock Plus

Follow these easy steps to disable AdBlock Plus

1)Click on the icon in the browser’s toolbar.
2)Click on the toggle to disable it for "mrexcel.com".
Go back

Disable uBlock Origin

Follow these easy steps to disable uBlock Origin

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back

Disable uBlock

Follow these easy steps to disable uBlock

1)Click on the icon in the browser’s toolbar.
2)Click on the "Power" button.
3)Click on the "Refresh" button.
Go back
Top