Why is the € being formatted by £ isn't?


Well-known Member
May 18, 2005
Office Version
  1. 365
  2. 2013
  3. 2010
  4. 2007
  1. Windows
I've noticed that when I type ALT 128 (the Euro symbol) into a cell in front of a number I get the following number format (I have the cell formatted as General when I'm inserting this currency symbol):

[$€-x-euro2] #,##0;[Red]-[$€-x-euro2] #,##0

I can type Alt 36 (the USD currency format) followed by a number and I get the following format:


But, when I type Alt 163 (the GBP currency symbol) followed by a number the cell is formatted as text and is still in General format. The cell's number format didn't automatically change to £ format like it for the € or $ currency formats.

I'm in the US and my regional settings are set to the United States. I would assume that since my Regional Setting is set to the $ that I would get a USD currency when I entered the dollar symbol. I looked at my regional settings and i don't see anything set up for the Euro currency format or any European settings.

I can't figure out why Excel converts from General number format to the Euro currency format when I type the € but it doesn't convert General formatting to other foreign currency formatting when I insert other currency symbols (£.¤. ¥ for example).

It seems that only the $ and € symbols will automatically change the General format from USD or EURO currency formats. However, this doesn't happen when I type in other currency symbols.

Can anyone explain what is happening behind the scenes? I wonder if this type of thing happens for computers that are Regional Settings are set to other countries other than the United States.

Thank you for your help in advance,



Some videos you may like

Excel Facts

What is =ROMAN(40) in Excel?
The Roman numeral for 40 is XL. Bill "MrExcel" Jelen's 40th book was called MrExcel XL.

Watch MrExcel Video

Forum statistics

Latest member

This Week's Hot Topics